NextGen API timeouts

Incident Report for Castlight Health

Resolved

Incident has been resolved
Posted Mar 05, 2025 - 09:36 PST

Monitoring

APC appointment smoke tests are passing. We are able to schedule, reschedule, and cancel appointments with nextgen.

Notes: Users who was still logged in may experience SQL errors if they don't log out and back in.
Posted Mar 05, 2025 - 09:36 PST

Identified

Interface server was restarted which cleared the api timeout issues
Posted Mar 05, 2025 - 09:34 PST

Investigating

We are facing timeout issues with NextGen APIs, which are responsible for APC appointment scheduling, rescheduling, and cancellation.
Already reached out to the NextGen team and awaiting a response.
Posted Mar 05, 2025 - 02:53 PST
This incident affected: My Vera.